Back to overview
Degraded

DDoS Incident

Mar 19, 2026 at 07:56pm UTC
Affected services
Web 2

Resolved
Mar 20, 2026 at 10:56am UTC

The attack is under control for the time being. We will continue to monitor this closely and provide updates as necessary.

Clients using Cloudflare and other proxying services may now safely re-enable these services.

Updated
Mar 19, 2026 at 09:32pm UTC

We have stabilised the situation, however the attack continues. Some clients may experience intermittent issues, particularly those proxying their site via Cloudflare. We suggest disabling Cloudflare proxying in the current moment as the attack persists.

Updated
Mar 19, 2026 at 09:00pm UTC

We are continuing to mitigate this significant attack with some success. Thank you for your patience.

Created
Mar 19, 2026 at 07:56pm UTC

We are experiencing a large-scale DDoS attack against our web2 service.

Customers using Cloudflare may experience loading issues with their site whilst traffic is routed via our DDoS scrubbing system.