Back to overview
Downtime
Client area unavailable
Mar 30, 2026 at 7:25pm UTC
Affected services
Billing
Resolved
Mar 31, 2026 at 2:58am UTC
This issue has now been resolved.
Affected services
Created
Mar 30, 2026 at 7:25pm UTC
An issue with our off-network hosting provider for our client area, OVH, is experencing an incident in ther London location. Please get in touch via support@zume.net for urgent support.
Affected services