Ams1 network incident
Resolved
Apr 3, 2026 at 1:56pm UTC
According to the datacentre, "the incident was caused by a chain reaction within the electrical systems, where safety mechanisms were triggered. A human action played a role in the sequence of events, in combination with the behavior of the underlying technical systems.".
A full RFO is expected by the end of next week.
Affected services
Updated
Apr 2, 2026 at 6:56am UTC
We are seeing services start to come back online. We will provide further updates as necessary. A full report will be provided here once we recieve it from our datacentre.
Affected services
Updated
Apr 2, 2026 at 6:30am UTC
The issue relates to a power issue. Engineers are currently on-site and working to restore service as soon as possible.
Affected services
Updated
Apr 2, 2026 at 6:22am UTC
We are still awaiting an update from our upstream network provider. Unfortunately no ETA is available at this stage.
Affected services
Updated
Apr 2, 2026 at 5:42am UTC
Unfortunately the network issue with our upstream provider has re-occurred. We are currently awaiting an update from them and will provide further details ASAP.
Affected services
Updated
Apr 1, 2026 at 11:28pm UTC
Network connectivity has been restored. We are continuing to monitor the situation closely.
Affected services
Created
Apr 1, 2026 at 11:25pm UTC
We are currently experiencing a network incident in our Amsterdam location. We are escalating to the transit provider and will update as soon as possible.
Affected services