Back to overview
Resolved
Dallas outage
Jun 28, 2026 at 3:54am UTC
Affected services
web1
Resolved
Jun 28, 2026 at 4:26am UTC
We have recieved confirmation from our upstream provider that the issue is now resolved. Apologies for the inconvenience which this has caused.
Affected services
Created
Jun 28, 2026 at 3:54am UTC
We’re currently expecting a network outage in our Dallas location. We’ve reported the issue to our upstream server provider and are awaiting a resolution.
Affected services