Back to overview
Resolved
UK Datacentre Network Incident
Jul 8, 2026 at 4:57am UTC
Affected services
Web 1
Resolved
Jul 8, 2026 at 5:36am UTC
We recently experienced a major network issue at our Coventry datacentre.
Service has now been fully restored for all customers, and a complete Reason for Outage (RFO) report will be published in due course via our status page
Affected services
Created
Jul 8, 2026 at 4:57am UTC
We are experiencing a network incident in our UK location. We're investigating the issue and will provide an update as soon as possible.
Affected services